Site5

Menu

Support Forums

Search not working when permalinks set to postname

Home Forums SimpleBright Search not working when permalinks set to postname

Tagged: 

This topic contains 28 replies, has 12 voices, and was last updated by  liuchunkai 1 day ago.

Viewing 15 posts - 1 through 15 (of 29 total)
  • Author
  • #1812

    addjanne
    Member

    Hello,

    I want the permalinks to be in domain.com/postname. But the search only works when I’m viewing the first page. I can see in the adressbar that the search has been executed, but not displayed.

    Is there a way around this?

    #1814

    Gabi Schiopu
    Keymaster

    It should work. You can test it on our demo, http://demo.s5themes.com/simplenbright/. Permalinks set to Postname

    #1815

    addjanne
    Member

    It returns a Epic 404 on both my site and on the demo site. What I would like is to show the search.php with the search results, even if there is no results.

    #1816

    Gabi Schiopu
    Keymaster

    you mean on your demo site or ours ? On our demo it doesnt return 404. Also, try to select the default WP postname option for permalinks, i suupose you added postname in custom permalink field. These can be tricky sometimes

    #1819

    addjanne
    Member

    For me it returns a 404 message. If I go to the contact page and do a search on the word “simple”, it returns a 404.

    I quickly swapped the settings back to default and it works. But when I put the permalink¬† to postname, it doesn’t work anymore.

    #1820

    Gabi Schiopu
    Keymaster

    Do you have any see or similar plugin installed ? if you do try deactivate it and try again. Also check if plugin is known to be compatible with your wp version etc. Again, if you do use a plugin.

    #1821

    addjanne
    Member

    Tested it on a clean install of WordPress and set the permalinks to postname and it doesn’t work there.

    Wordpress v. 3.4.1

    • This reply was modified 5 years, 4 months ago by  addjanne.
    #1823

    Gabi Schiopu
    Keymaster

    No reason not to from the theme itself. Dont know what to say anymore. We can’t reproduce the issue as on our demo works just fine as you can see.

    Asking you again, do you select the default wp option for postname or you add some parameter in the “custom permalink structure” on permalinks settings page?

    • This reply was modified 5 years, 4 months ago by  Gabi Schiopu.
    #1824

    addjanne
    Member

    It is happening to me on your demosite aswell. You can check a screenshot here.

    #1826

    Gabi Schiopu
    Keymaster

    This screenshot doesnt help me, pls post one with your permalinks settings page.

    #1827

    addjanne
    Member

    I select the option for postname in the radio buttons. I do not write the code /%postname%/ in the custom value box.

    #1828

    Gabi Schiopu
    Keymaster

    ok, sorry, i might have read you messages wrong. I see the issue now. You are right. Ok, let me look into it a littlea and we will get back once we have a fix for it. Thanks and sorry again!

    #1829

    addjanne
    Member

    It’s in swedish, hopefully you can make out the radiobuttons. Here’s a screenshot.

    #1830

    addjanne
    Member

    No worries! Thanks for the quick replies and I hope you find a solution soon.

    #1831

    Gabi Schiopu
    Keymaster

    OK, found the issue. On header.php, on line 114, on the form tag, beside the method=”get” alo add this:

    action=”<?php bloginfo( ‘url’ ); ?>”

    It will solve this issue, sorry for this …

Viewing 15 posts - 1 through 15 (of 29 total)

You must be logged in to reply to this topic.